Forums

Full Version: BSOD on boot after successful Windows 7 installation
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I'm trying to install Windows 7 on a 1TB USB hard drive with Win2USB. The installation completes successfully, but once I reboot and Windows starts to load, I get a BSOD. I've tried the following scenarios:

1. Installation from Windows 7 DVD
2. Installation from existing Windows 7 hard drive
3. Changing to another USB HDD casing
4. Booting up in safe mode

In all scenarios I'm getting BSOD upon booting up.

Here's the BSOD

https://www.dropbox.com/s/6oeuwkaq5tyb6xu/IMG_20150709_102440.jpg?dl=0

What's wrong?
Windows 7 to go drive must boot from USB 2.0 port, please make sure that the drive is boot from a USB 2.0 port.
Turns out it's the BIOS SATA setting. I have to set it to SATA (I'm guessing this is legacy IDE mode?) instead of AHCI. I didn't think it'd matter.
I'm having a similar problem now on the same drive.

After a fresh Windows 7 Pro SP1 64bit installation, it works fine once I set the BIOS SATA setting to ATA instead of AHCI. However, after I install device drivers (Intel chipset drivers, USB drivers, networking drivers, audio drivers, etc) and reboot, then I get the same BSOD.

I tried switching back to AHCI thinking perhaps the installation of the chipset drivers might have enabled AHCI somehow, but still no go. What else could it be? The USB 3.0 drivers perhaps? On the Win2USB main page it states:

Quote:•Windows 7/2008 R2 does not have built-in USB 3.0 support, so Windows 7/2008 R2 will have to be booted from a USB 2.0 port.

My laptop only has USB 3.0 ports though. Could it be that prior to installing the USB 3.0 drivers Windows treats my USB 3.0 ports as 2.0 ports, and only after I installed the USB 3.0 drivers, it recognizes them as USB 3.0 ports and then stops working? How can I make this work?

I've installed on a USB 2.0 drive btw.
(07-09-2015, 11:00 PM)admin Wrote: [ -> ]Windows 7 to go drive must boot from USB 2.0 port, please make sure that the drive is boot from a USB 2.0 port.

I installed WIN7 pro with USB port 2.0, system works fine. then I installed USB3.0 drivers on it. after that, I got BSOD when booting up. I tried both USB3 and USB2, same result. It seems Win7 cannot load USB3 drive during boot process even the drivers are installed already?
(09-29-2015, 11:59 PM)newnews Wrote: [ -> ]
(07-09-2015, 11:00 PM)admin Wrote: [ -> ]Windows 7 to go drive must boot from USB 2.0 port, please make sure that the drive is boot from a USB 2.0 port.

I installed WIN7 pro with USB port 2.0, system works fine. then I installed USB3.0 drivers on it. after that, I got BSOD when booting up. I tried both USB3 and USB2, same result. It seems Win7 cannot load USB3 drive during boot process even the drivers are installed already?

Microsoft does not provide a USB 3.0 driver for Windows 7. Some vendors have their own USB3.0 drivers for Windows 7, but we have never tested it, so WinToUSB drive may not work properly if you use a third-party USB3.0 driver.

We recommend you to create a Windows 10/8 To Go drive, then you can boot it from a USB 3.0 port, it is more safe and reliable.