Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB functionality during WinPE cloning
(06-28-2016, 10:20 AM)admin Wrote:
(06-28-2016, 06:54 AM)videoclarity Wrote: I am trying to clone the current operating system which is Windows 7, to USB and will get stuck as soon as the PC has been restarted and WinPE has loaded to start the clone process. Then, an Error message pops up and reads "Specified disk not found. (0x0005003501480000)"

My keyboard and mouse are no longer functioning either. The USB flash drive and keyboard/mouse are both plugged into USB 2.0 ports.

I also came across this situation with USB ports not functioning when trying to install Windows 7. And after an hour of searching online, basically I had to create a Windows 7 Installation image with xHCI drivers included, according to Intel. This was all explained in a technical white paper addressing EHCI Removal from 6th Generation Intel Core Processor Family PCH which explains why we aren't able to use a keyboard and mouse, and any devices plugged into any USB ports when booting with a Windows 7 install cd, Windows Repair utility.

I attached a copy of the white paper released by Intel to help give a better understanding because I'm not doing a good job of explaining my problem here. Hopefully it will help.

Is there a way to include USB drivers to the WinPE image building process in wintousb?  

Any help with this is appreciated! I know I left out alot of information so please ask away.

Here are the steps to setup for and inject the drivers into the boot.wim file with dism.exe.

    1. Create the following folders on the root of the C drive:
    2. Copy the drivers you wish to inject into the C:\Mount\Drivers folder
    3. Copy C:\Program Files\WinToUSB\bin\boot.wim to the C:\Mount folder.

    1. Open a CMD prompt as Administrator.
    2. Navigate to "C:\Mount".
    3. Use the following dism.exe commands to mount the boot.wim:
        dism.exe /Mount-Wim /WimFile:C:\Mount\boot.wim /Index:1 /MountDir:C:\Mount\BootWIM
    4. Use the following dism.exe command to add the driver:
        dism.exe /Image:C:\Mount\BootWIM /Add-Driver /Driver:C:\Mount\Drivers /recurse
    5. Use the following dism.exe command to unmount the boot.wim:
        dism.exe /Unmount-Wim /MountDir:C:\Mount\BootWIM /Commit

Cleanup and Clone:
    1. Copy the newly updated boot.wim file from the mount folder back to the C:\Program Files\WinToUSB\bin\ folder.
    2. If desired, you can delete the C:\Mount folder and its contents.
    3. Try cloning again.

It worked!  Big Grin  I was able to clone to USB. Many Thanks!! I appreciate your help

Messages In This Thread
RE: USB functionality during WinPE cloning - videoclarity - 06-29-2016, 03:21 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)