Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Application error 0xc000007b
Hi, guys -

We're interested in using your command line utility to detect custom USB keys and automatically reboot to them from our application. It's written in C# against .NET version 4.5.2.

I've installed a "trial" of your Enterprise software.

When I run either EasyUEFI.exe *or* EasyUEFIC.exe from the command line, or using the application shortcut, everything is fine.

When I copy your EasyUEFIC.exe and supporting DLLs to our application's folder and set up a new Process to spawn for it, I get a popup saying "EasyUEFIC.exe - Application Error" and "The application was unable to start correctly (oxc000007b). Click OK to close the application." And sure enough, it quits, even before producing any sort of log.

In general, I'm doing this:
System.Diagnostics.Process shellpro = new System.Diagnostics.Process();
            System.Diagnostics.ProcessStartInfo startInfo = new System.Diagnostics.ProcessStartInfo();
            startInfo.WindowStyle = System.Diagnostics.ProcessWindowStyle.Normal;
            startInfo.WorkingDirectory = System.Environment.CurrentDirectory;
            startInfo.FileName = "EasyUEFIC.exe");
            startInfo.Arguments = "--list-efi";
            startInfo.UseShellExecute = false;
            startInfo.Verb = "runas";
            startInfo.LoadUserProfile = true;
            startInfo.RedirectStandardOutput = true;
            startInfo.RedirectStandardError = true;
            startInfo.CreateNoWindow = true;

            shellpro.ErrorDataReceived += Shellpro_ErrorDataReceived;
            shellpro.StartInfo = startInfo;

// this is where the error crops up.

The idea is we will capture the UEFI boot devices and parse it out for our particular USB key.

I've tried it with and without "runas" and LoadUserProfile.

I've tried it changing the command to "cmd.exe" with parameters "/c EasyUEFIC.exe", and even inside a batch file.

This code was working when a coworker handed it to me, running against EasyUEFI version, but his trial license had expired and I downloaded 3.0 instead.

Running Windows Version 10.0.15063 Build 15063

Any suggestions?

Messages In This Thread
Application error 0xc000007b - rrussell - 10-07-2017, 03:26 AM
RE: Application error 0xc000007b - admin - 10-07-2017, 12:17 PM
RE: Application error 0xc000007b - admin - 10-09-2017, 10:36 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)