Hasleo Software Forums

Full Version: W7 x32 Installation on USB
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi @ all,

first of all, sry for the bad translation, iam not a native speaker and used Google Translate my origin post in a germen windows 7 forum. I read this article trough to find the mistakes in grammar, but i think i missed a lot.... forgive me for that and reask me for what is unclear what iam meaning. Thx

I trysince 2 months and over again to solve a problem that I do not get solved, I understand as a matter not at all and hope for enlightenment .....

Straight away, I have read here in the forum in the last few days first and previously also often the Google search used to avoid double posts. So completely correct solutions but I have so far not found ...

What ever I wanted to make, install Windows 7 on a USB flash drive so that I can use it with different amd or intel machines.

I used this programm: WinToUSB V2.2 Beta.
This USB stick I have planned to use for installation: Scan Disk Extreme 64GB USB3.0

My host environment in which I have carried WinToUSB is deposited in the DxDiag.txt.

WinToUSB started, Genuine Windows 7 x32 InstallationDVD, and then used WinToUSB to make the USB Stick ready.

To turn out conflicts with my host system, I have turned off the SATA support in the BIOS and thus deactivated my hard drive, into the USB selected options that the USB stick should be seen as a HDD and then set the drive in the boot sequence. Even if it is a 3.0 Stick I have this plugged into the 2.0 port.

Windows installed on this USB flash drive runs smoothly. After successful installation, all the drivers on the host system installed by the original driver DVDs. Multiple restarts of the operating system had no problem at all.

So far so good.

Windows 7 is not ready yet, as the update and the service pack 1 must also still plan, other programs such as Office, etc. not to mention. No sooner said than done, Service Pack 1 downloaded and started the installation. No error message (s) during the installation process, at the end of the installation the reboot is required as usual.

System reboots and ends in a BSOD. Again reboot and reach the Safe Mode in attempts at the list of drivers he was then also at the ends in a BSOD.

Then I thought to myself, am pretty stupid, why I did not integrate the SP 1 in the InstallationDVD as before with XP, also implemented, SP integrated, or also get again and again reacted with WinToUSB.

This time I'm not even in the installation routine pure, he loads the Windows logo before you install and then ends again in the same BSOD.

I've even read a lot now, with all the differences, as internal or USB removable disk, the pure win me is installed on USB permits not even the selection also clear.

What I simply do not get is that I managed the first installation without SP1 and only through the update is all useless.

What I've tried. Is a Win7x32 installation furnished with Oracle VM VirtualBox Manager, disk slightly smaller than the left USB stick. All installed, all drivers, programs ect what I wanted so and then with "Clonezilla Live 2.4.2-10-i686-pae" booted into the Virtual Machine and per Device Device clone the contents of the virtual disk to the USB stick...

clonezilla seems not working correctly, so i tryed another different programm, "Acronis Image 2015" and cloned the virtal disk with installed win7x32 to the usb stick, but also not working.

Cloning worked, but the USB stick does not start at the host computer on which I tested all the time .... still not working, still the BSOD.

I found in this forum a link to another side, with explanations to fix the BSOD, i try that out in the afternoon. Happy about any other idea to fix that.

If you need more information regarding to my host system, let me know.

Please Please bring me enlightenment, good time for all

Hi people, i could not find a solution in combination with WinToUSB.

I found another Guide to make the hole thing working.


I used a Win7x32 ISO included with Service Pack 1 and it seems to be working. I test now the change to another computer with another hardware configuration, maybe it works and this is my solution....