Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No Bootable Device
Dear Hasleo Team and Fellow WinToUSB Users,

I have got a rather strange problem:

I successfully installed Windows 8.1 Pro onto a Samsung Fit 128GB USB. I intend to use this as a bootable on the go Windows drive.
I installed all necessary drivers with BootCamp and got to run Windows 8.1 on my MacBook Pro 13" Late 2013 (retina).

Now to the problem: Everytime I shut down the MacBook Pro and try to boot (MBR) from the Samsung fit again I get the "no bootable device - insert boot disk and press any key" message right at the startup.
BUT! when I then try to boot from the same USB drive on my iMac 27" Late 2012 (FusionDrive) I can successfully boot Windows. After shutting down from my iMac, going back to my MacBook I can boot as well on my MacBook Pro. But when I shut down on my MacBook and try to reboot I am again prompted with the "no bootable device" message. WTF?!

I am pretty clueless about what to do next. I tried reinstalling Windows 8.1 and got the same result.

Just to sum up my problem:

Boot from USB on MacBook Pro --> no bootable device

Boot from USB on iMac --> Windows boot perfectly

Boot from USB on MacBook right after iMac boot --> Windows boot perfectly

Boot from USB on MacBook again after shutting down --> no bootable device

I do not want to EFI boot (cause that doesn't work unless you shut down system integrity)
The Windows Installation does completely work on said MacBook

I am very very thankful for every advice you can give me!

Messages In This Thread
No Bootable Device - HansPeter - 02-22-2018, 05:59 AM
RE: No Bootable Device - HansPeter - 02-23-2018, 04:01 AM
RE: No Bootable Device - admin - 02-23-2018, 02:09 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)