Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Read Only - I/O error
Greetings! I have been using WintoUSB for the past few months now on a spare laptop to stream Netflix to my television. All has been well until randomly I got a BSoD with the error, "Registry_error." Upon resetting, it just BSoD no matter the option chosen.

The real problem is that it BSoD'd whilst running Windows on a password protected administrator account so I suspect the Hiberfil (or something similar) locked my USB drive up super tight. Every method from Windows Diskpart to Linux's Gparted results in the same error... the dreaded Read Only. When attempting to take ownership of the drive it continues to tell me, "contents are read only." I've tried the Sandisk website but there's no specific tool for recovering or reformatting their brand of flash drives. ...even Dban can't nuke the thing...

I've noticed on my Linux Mint side that Linux has trouble mounting any Windows partition that has been shut down irregularly and I fear it's been locked out permanently considering there's no way to boot into the system that I've found.

My only hope, it seems, is if I could make a mock recovery image of some kind to trick the drive into thinking I'm restoring it but I really don't know Windows well enough in that area to know if that's even possible... I'm at a total loss with how to reformat this drive and get rid of the read only!
I feel my only options are to somehow boot into Windows 7 despite always being presented with the BSoD, "REGISTRY_ERROR."

The drive is quite large at 128gb and I really don't want to trash it if there's even a glimmer of hope in recovering it. Any advice would be super helpful! Thank you!
Sorry, We have never encountered such a situation. Could you contact your hardware manufacturer for support?
The device is a Sandisk Cruser and the hardware manufacturer was of no help...

I encountered the error with LiLi as well just recently! I really need to isolate this problem and hopefully get a fix as it's obviously to do with live operating systems on USB devices.

Just like Windows, Linux (Mint) booted up and ran just fine for several days with absolutely no problems. After a casual restart of the system it hangs on the boot logo with F1 telling me that all the files are suddenly read only. This happened on a completely separate system... I have only once had a USB drive just die on me and it seems this is not the case as the files are completely readable but cannot be deleted or modified.

I shared the disk with full permissions, navigated to my network pane and attempted to add a folder with the error "ERROR 0X8000FFFF: Catastrophic Failure"
I checked my 128gb drive and it does the same thing.

Two separate drives with two different live operating systems made with two different computers... what am I missing here? Everything I've tried eventually leads to "Disk is write protected."
It seems that the sandisk cruzer became read-only is a very common problem, you can google "sandisk cruzer read-only". I'm very sorry, the device may be damaged.

Forum Jump:

Users browsing this thread: 1 Guest(s)