Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Win 10 and WtGU 2.8

Problem with WtGU 2.8 -

host PC:
a) Windows 10 Pro 64b ver. 1903 on ssd with a lot of RAM, AMD-v supported and enabled
b) WtGU 2.8
c) Oracle VM Virtualbox 5.2.22
d) latest Win 10 iso

WtGU starts creating a VM but stops at 5% with error "Failed to run system API.(0X0002001502990000)", both on "Check"-button and "Upgrade"-button.

I tested it on Win 10 Pro ver. 1709 tool - same result with the same error message - it was before i upgraded Win to ver. 1903

Attached Files
.txt   user.txt (Size: 57.16 KB / Downloads: 1)
Please download and install W2G Upgrader and VirtualBox version below and try again.

Tnx for replay, but ... nothing. Exact same results, same error message, same error code.
User.log added.

Attached Files
.txt   user.txt (Size: 20.02 KB / Downloads: 3)
Is the Windows To Go USB drive a Legacy or VHD(X) mode Windows To Go? And please don't install and run 'Windows To Go Upgrader' on the Windows running on the USB drive which you want to upgrade, you should install and run it on other Windows operating systems.
1) Legacy, not VHD (on SSD over USB3);
2) WtGU is not installed and run on HDD i want to upgrade - i know that.

More than a year ago i upgraded my WtG 10 successfully; don't remember what ver. of W10 i was using back then.
It's so strange that we have never encountered this situation before. We've analyzed the log file and the program prompts the following error message:
VBoxManage.exe: error: Cannot open the raw disk '\\.\PhysicalDrive4': VERR_SHARING_VIOLATION
VBoxManage.exe: error: The raw disk vmdk file was not created

This usually means that there are other programs using this disk, do you confirm that no other program or another virtual machine is using it? Can you try it on another computer to see if it works? Or can you set the save path for the virtual machines as the default path?
It works!

So, there was an other programm, took me a while to figure it out: Paragon ExtFS for Windows. After i shut down the processes and services everything seems to be working.

Thanks for the tip!


PS. full test can be carried out in weekend only, so far OK.
I'm glad to hear that you've solved the issue. If you have any other questions, please feel free to contact us.

Forum Jump:

Users browsing this thread: 1 Guest(s)