Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VirtualBox fails with "Inaccessible Boot Device" BSOD
(05-13-2017, 04:20 PM)admin Wrote:
(05-13-2017, 12:03 AM)marcelser Wrote: Hi,

I was unsuccessful trying to run my WinToUSB stick's image in Virtualbox so far (obviously I don't know how to correctly set it up, for example where to put the boot partition etc.).

So I though let's try the Windows To Go Upgrader because it does exactly what I need, creates a VirtualBox Image from the WinToUSB Stick. So I downloaded it and started the "check for upgrade" with a "Windows 10 Pro (x64)" GPT/UEFI WinToUSB enabled USB Stick. The process starts and creates the VM and tries to start it. At first I see the virtualbox logo and the turning dots at the bottom which everyone knows, but after about 5-10 seconds I get a BSOD saying "UNMOUNTABLE_BOOT_VOLUME". So, question is, whe isn't it able to boot? I'm using Virtualbox 5.1.20.

I would be even be willing to pay if I can boot the WinToUSB image so I can modify it. And it also seems that other people are having also big problem to boot a WinToUSB volume in Virtualbox if you look into the forum threads about WinToUSB.

Any help would be greatly appreciated.

Best regards,


Unmountable boot volume error is usually caused by corruption of files on the disk or corruption of the file system, so please make sure that the Windows To Go drive is not damaged and can boot normally then try again.

Of course I did this already. The USB stick itself boots perfectly and has no errors, but still doesn't boot in Virtualbox when the VM is created from WinToGoUpgrader. I think it has something to do with the fact that the vhd file which the UsbToWin media is created from only contains the OS partition but no recovery nor EFI partitions because it is a copy of the system partition as a vhd disk from some backup some time ago. It seems this can be booted perfectly from the USB Stick made by WinToUSB but not with how the Virtualbox image from WinToGoUpgrader.

I think that's the case because I did a lot of testing after my forum post and I found out the following: I created a new empty vm in Virtualbox and installed Win10 Pro into it from installation DVD. Once installed I created a new WinToUSB version on my stick (so I replaced the existing one which won't boot in WinToUpgrader) from this newly created win10 pro vm disk . When I use this USB stick and run WinToGoUpgrader it creates a vm that just boots fine. But this time the originating vhd file which was used to created the WinToUSB media contained a recovery, efi & system partition in the disk. So I repeated my previous step and created a new WinToUSB installation again from the vhd disk which just contains the OS partition and it failed again when trying to use it in WinToGoUpgrader with the same error UNMOUNTABLE_BOOT_DEVICE.

It seems that WinToGoUpgrader definitly needs some improvement so also WinToUSB imgaes with vhd images without efi/recovery partitions contained in them can be booted not only disks that contain this, or maybe you must modify the supplied vhd image in WinToUSB inserting any missing partitions when creating the WinToUSB Media.

Best regards,


PS: Once I get a big enough USB stick I might try to create a USB stick from my existing windows partition and check how the created vhd disk looks like. Do you also copy the recovery/efi partition into it or not?

Messages In This Thread
RE: VirtualBox fails with "Inaccessible Boot Device" BSOD - by marcelser - 05-13-2017, 04:56 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)