Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Massaging an existing Windows installation to boot USB
Nothing like Replying to your own question, but here's what has work once so far.

The Source & Clone are EFI boot. To get the Clone disk to Start, the EFI BCD had to be modified to reflect the Clone Disk Signature. Don't mess with BCDBoot & BCDEdit, you could wind up with some very unexpected results. Diskpart will reveal the Disk Signature\GPT Partition GUID\uniqueid, but it's encoded (the first 8 bytes anyway), on the physical disk at offset 0238. Find & Replace occurrences of the Source Disk signature in the Destination Disk/Clone EFI BCD with That disk's signature.

In the Registry of the Clone, I Swap the Source (C:) and Destination (D:) DOSDevice assignments. (This may not be necessary on Windows 8.1 but is a carry over from my Windows 7 cases where the clone disk only physically replaces the source.) At HKLM\System\MountedDevices\. Export the MountedDevices key. I pre-prepare a couple of .reg files edited down to only the specific entries, to load to a False Key name, i.e. HKLM\{False Key}\MountedDevices\ with the 2 DOSDevice assignments binary data swapped between C: & D:. On Windows 7 the Volume assignments were swapped as well to keep the Volume Labels straight but Windows 8.1 doesn't seem to need this. Then at:

"BootDriverFlags"=dword:00000000 // for SATA 00000014 for USB

Under HKLM Load the System file\Hive of the clone into the running registry under a False Key name. Merge the pre-prepared .reg file(s). And Unload the False Key hive which writes the modified hive back from were it came. Shut Down, Start, and I get the Boot Possibilities by holding Down ESC on Start (Asus). Point the computer to the EFI possibility on the USB Enclosure.

This didn't work on the first go around? Windows would begin to load and then stop, complaining of Configuration Errors. Unrelated to this work I then Borked the Windows installation screwing around with things "you're not meant to play with". After Recovering the entire internal disk from an AOMEI Backupper Image made a couple days before, I had lost the Clone Boot work and had to remake that. Then as a parting gesture I tried to boot the exact same setup again on the what you might call a fresh build? It stuttered a bit and then took off and worked! After the troubled first start everything has been completely normal on a 100% copy of the original Windows 8.1 installation running from USB.

Windows is a Very Dynamic thing. Now I want to know Why first it wouldn't, and then it would? As this may affect the ability to Switch the clone back to SATA? But what an achievement, a bootable on USB backup. Not to mention an Easy WinToUSB installation. Just make a copy of what you've got, change three things, and boot it up!


Messages In This Thread
RE: Massaging an existing Windows installation to boot USB - des421 - 01-25-2015, 06:29 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)